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I. Introduction 

A. Preface 

Welcome to IVEO - a hands-on graphics system that combines touch and sight with audible information 
and sounds to make graphics more accessible for all, including people with visual or learning disabilities. 
With IVEO you can view existing accessible graphics, create accessible graphics, or convert inaccessible 
graphics to accessible ones!  
 
The IVEO system consists of three software components and a choice of hardware component: 
 
Software:  
 

• IVEO Player: End user application to view, explore and learn from existing IVEO files. Included 
with IVEO Creator and Transformer Pro in the professional package, and available separately for 
end users. 
 

• IVEO Creator: Create your own interactive files using Adobe Illustrator, CorelDRAW, Microsoft 
Visio, InkScape, or any other program that saves or exports to SVG and complete editing in IVEO 
Creator. 
 

• IVEO Transformer Pro: Import image files or scan printed materials using IVEO's advanced OCR 
technology, and convert to your own interactive files. Transformer Pro and  
Creator are separate applications but both are included in the IVEO application set for 
professional content preparers. A separate user manual is available for Transformer Pro. It is not 
included within this manual. 
 
 

Hardware: 
 

• IVEO Touchpad – a touch-sensitive pad for reading text labels 
and graphical object names on tactile-audio images up to a size 
of 11x14 inch, or 28x35 cm. Multiple touches speak additional 
descriptive information. IVEO touchpads connect through USB. 
 
 

• IVEO Digital Pen – a digital pen with an IR transmitter whose position is determined by an IR 
receiver attached to the PC through USB. Standard mode has functionality similar to the touchpad 
where clicking causes text labels or graphic objects to speak their content. More descriptions 
available by multiple clicks. Follower mode speaks without clicking when pen passes over a text 
label or graphic object. 
 
 
 

Keep up to date by checking the ViewPlus Technologies, Inc. web site at: 
www.ViewPlus.com 

http://www.viewplus.com/
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B. Specifications 

Operating System  Windows 7, 8, or 10 

CPU      Pentium 1 GHz or better 

Memory 512 MB or more 

Display resolution  800x600 or more 

Hard drive use up to 350 MB of free space 

 

II. IVEO System Setup  

A. Software installation and activation  

For installation of any of the IVEO software components you will have received an installation file (ending 
.exe). It's best if it will be copied to the computer locally before executing installation. Please find the 
installation file using Windows File Explorer and press Enter or double click on the file to start installation.  
The installation program will guide you through software installation with on-screen instructions. Please 
follow these instructions to complete IVEO software installation. 
 
After IVEO software installation has completed successfully, it will appear under Windows 
Programs/Applications list within the ViewPlus section, or find installation files under c:\Program Files 
(x86)\ViewPlus using the standard Windows file browser. 
 
All IVEO software requires activation using the purchased IVEO license number. Upon startup, the 
application will ask to activate the software as described below. Without activation the software will stop 
working after 30 days.    
 

Activation of IVEO software: 

When starting the IVEO application, the following window will pop up asking for IVEO Activation. If 
cancelling activation, a message will prompt to you how many more days you can use the software 
without activation. 
 

 
IVEO software activation options 
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The window shows four buttons. With an existing internet connection, option "Activate online" will be 
most efficient. Both "Activate online", and "Create file for activation" will open a dialog window for 
entering registration information, but with different activation buttons at the bottom. Please complete 
this form. 
 

 
IVEO software activation form 

 
Online Activation: 
If you have entered a valid IVEO license number, the activation process will be done when hitting "Activate 
online".  
 
You might get a warning before the form is accepted to not have supplied enough contact information. 
You can return to the registration form or proceed with activation anyway, but please be aware that this 
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information is important in order for ViewPlus to be able to provide support if any serious problems, such 
as a computer crash, should occur.  
 
Activation by File: 
With "Save to Activation File" the data entered to this form will be saved to file and you should receive 
the following message. 
 

 
IVEO software activation file successfully saved 

 
Next you should take the file to a computer with internet connection and visit the ViewPlus website 
software activation page at https://viewplus.com/viewplus-support/activate/ 
 

 
IVEO software activation file upload 

 
Browse to the IVEOActivationRequest.dat file and submit the upload. In return you should receive a 
request to download the activation response file. It is recommended to save this to the same location as 
the request file, or at least to a known location. 
 
Now you can return to the computer running the IVEO application to activate. After starting the 
application, choose "Activate from activation file" within the first prompt.  
 

 
IVEO software activation options 

https://viewplus.com/viewplus-support/activate/
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Browse to the IVEOActivationResponse.dat file and open it. Now activation should be completed.  
 

 
IVEO software activation completed 

 

B. Deactivation and Uninstallation 

If you wish to deactivate your IVEO product license, open your IVEO application and choose the 
deactivation option from menu "Help". 
  

 
IVEO Player, or Creator "Help" menu 

 
A small window will pop up asking for your preferred method of deactivation. In principal it is the same 
procedure as explained for the activation procedure explained above. Please refer to that description to 
accomplish deactivation. 
 

 
IVEO software deactivation options 
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After deactivating your IVEO software you might also want to uninstall it from your computer. Please refer 
to your Windows system functions to uninstall ViewPlus IVEO software from your Windows PC. 

C. IVEO Input Devices 

For the full end user experience getting audio feedback when reading tactile prints through touch, an 
input device is required that can recognize the position of current user touch on the embossed/printed 
paper. The IVEO software will evaluate the given position and return information stored to any object in 
the document that includes this position. 
ViewPlus offers two devices to fulfill this purpose.  
 
IVEO Touchpad, or IVEO Pen 
 
Please install one of the IVEO software components before connecting either one of them to your 
computer through USB. 
 

IVEO Touchpad 

The touchpad is a glass plate where a copy of a tactile print is laid on. It is a touch sensitive glass which 
recognizes the position of a touch when pressing any point on the tactile print that covers the glass. The 
print should be registered to one corner within the frame surrounding the glass, and fixed with the long 
clamp which is part of the touchpad frame assembly. 
When connecting the IVEO Touchpad to your computer through USB, Windows will install a generic driver 
for this device. But please note, that it is essential for proper functionality in IVEO applications, that the 
touchpad driver is installed again calling "Install Touchpad Driver" from submenu "Input Device" in menu 
"Tools" of IVEO Player, or IVEO Creator. (Please see section B. of chapter III below "Calibrating the IVEO 
Touchpad")  

IVEO Pen 

The pen is a digital pen which sends position signals to a receiver. The receiver, which is connected to the 
computer through USB cable, is a small device clamped to one corner of the tactile print. The pen can be 
used freely to tip any point on the tactile print that is being explored. 
The Windows device driver for the IVEO Pen will install automatically upon connection through USB. It 
may take a few minutes though, before the pen will show under peripheral devices on your computer and 
is ready to be used.  
 
Note: In order to receive correct information feedback when using IVEO Touchpad, or Pen, the SVG file 
associated to the specific print that is being explored, needs to be opened in IVEO, and the positioning of 
the print needs to be calibrated correctly. Please see section A. and B. of chapter III. ("Getting started with 
IVEO Player") below to learn more about these requirements for a satisfying IVEO experience.  
 

  



8 
 

D. IVEO Speech 

The whole point of IVEO is to provide audio information while exploring a tactile graphic by touch. Besides 
playing sound files assigned to specific objects within an SVG document, the creator of such SVG 
document is given the opportunity to insert text for object titles and descriptions. This text information, 
as well as any IVEO user interface label, and messages are being converted to speech using system voice.  
 
Screen Reader Voice: If IVEO finds an active screen reader application on the users system, the screen 
reader voice will be used automatically for IVEO audio feedback.  
 
Without a Screen Reader: If IVEO does not find an active screen reader application on the users system, 
it will look for voices installed on the system without association to any application. If you would like to 
add voices to your system for IVEO, please make sure to install  
 

- MS Speech API version 5 (SAPI5) compatible voice for use in IVEO Player and Creator 
 

- MS Speech Platform Version 11 compatible voice for use in IVEO Transformer Pro  
 

 

III. Getting started with IVEO Player 
 
The picture below shows the main application window of IVEO Player. It's a simple application window 
with a menu bar at the top left, and a minimize, as well as an exit button at the top right corner. The 
menus and commands are as described in the following sections.  
At the very bottom of the main application window all feedback messaging from the application will be 
displayed as text. 
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IVEO Player main application window 

 

A. File opening 

IVEO Player will open files with extension SVG, or HTML, which have been prepared to contain objects 
with background information, that will be given in audio feedback to the user exploring this file within 
IVEO application, or exploring a tactile print from the file using an IVEO input device. 
 
Within the "File" menu of the IVEO Player application the user will find several options for file opening: 
 

 
IVEO Player "File" menu 

 

• File -> Open (Ctrl+O, or Alt+F+O): This options will open up a standard Windows file browser dialog, 
allowing the user to choose a file to be opened. 
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When wanting to receive feedback exploring a printed document using IVEO touchpad, or IVEO pen, it is 
mandatory that the file being opened in IVEO Player matches the printed document. 
 
To identify file sources corresponding to IVEO prints, the software includes features for a barcode system, 
which is easy to use, even without any reading skills. 
 

 
IVEO Player "File" menu item "Barcode" 

 

• File -> Barcode (Alt+B): In a submenu to this menu item you find two choices for opening a file 
corresponding to a specific tactile print that the user would already have on-hand. This print would 
have been created out of IVEO, using a ViewPlus embosser.  

 

 
Preview of tactile IVEO document print 
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Such print would include the IVEO three point barcode within the top margin of the page. It's a row of 
framed cells, and the user would find three points distributed within this row from left to right. 
Additionally, an index number is printed in vertical Braille label within the left margin. This index number 
is related to the barcode combination and can be used alternatively to open an IVEO file corresponding 
to a certain printed view. 
 

• File -> Barcode -> Open from barcode (Ctrl+B, or Alt+B+B): With this option the file corresponding to 
a certain tactile print from IVEO Player, Creator or Transformer Pro, can be opened by pressing the 
three points of the barcode. When using an IVEO input device to do so, please make sure it is 
calibrated correctly to the current printed image first. (See section B. of this chapter below) 
  
After selecting this option, the IVEO application will show a representation of the barcode frame as 
seen in the picture below. The user will be instructed to find and press the three barcode points one 
after the other from left to right, and pressing SPACE after each one to confirm.  
If the points are hit correctly and IVEO finds the corresponding file to this barcode within the local 
standard IVEO SVG file folder, the file will open and the image of the document will show within IVEO 
application window. The local standard IVEO SVG file folder is the users local "…\Documents\Svg" 
folder. 
If no file is available from the barcode entered, IVEO will give a message and return back to the state 
as before trying to open a new file from barcode. 
 

 
IVEO application window when opening file from barcode 

 

• File -> Barcode -> Open from index (Ctrl+I, or Alt+B+I): With this option the file corresponding to a 
certain tactile print from IVEO Player, Creator or Transformer Pro, can be opened by selecting the 
index number embossed in Braille on the page. 
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After selecting this option, a dialog will show as in the picture below. Select the drop down list box for 
"Index" and start entering the number that you read from the Braille label of the print. If the 
corresponding file has previously been saved under the local standard IVEO SVG file folder, which is 
the users local "…\Documents\Svg" folder, IVEO will find it in the list and display the full index and file 
name. Now click the "OK" button to open the file. 

  

 
IVEO open file from index dialog 

 
Additionally, menu "File" also contains item "Recent" for file opening, complying with standard feature in 
mainstream applications. 

 

 
IVEO Player "File" menu item "Recent" 

 

• File -> Recent (Alt+F+T): Opens a submenu, listing recent files in chronological order. Select one of 
them to be opened.  
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B. Calibrating your IVEO input device 

After a file has been opened, you need to make sure your IVEO input device is calibrated correctly to the 
printout that you are aiming to explore. This is important to get accurate feedback for the objects that are 
being touched. 
 
First, it will be necessary for you to select the input device that you are using in connection with your IVEO 
application. 
 

 
IVEO Player "Tools" menu item "Input Device" 

 

• Tools -> Input Device -> Select Input Device (Alt+T+I): Select "Input Device" from menu "Tools", and 
go to first item of following submenu. The label of this menu item will state the currently selected 
input device in square brackets. If the one stated here is not the one in use, open the dialog to switch 
to the other input device by clicking "Select Input Device …".  
 
 

 
IVEO Player "Tools" menu item "Input Device" 

 
A dialog will open where either IVEO Touchpad, or IVEO Pen can be selected from the drop down list 
for "Input Device". Make the selection and click "OK". 

 

Calibrating the IVEO Touchpad 

After IVEO application knows which input device you are using, you can perform options to calibrate the 
positioning of tactile points on embossed output to match corresponding x, y coordinates of the SVG 
image loaded within the IVEO application window. 
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Please note, that the proper driver for the IVEO Touchpad device has to be installed once before beginning 
to use the Touchpad with any other options. See explanation of menu item "Install Touchpad Driver" first 
in the list below. 
 

 
IVEO Player "Tools" menu item "Input Device" 

 

• Tools -> Input Device -> Install Touchpad Driver (Alt+T+I+D): This will start a Windows advanced 
installer with a first prompt that will ask whether you would allow this app to make changes to your 
device (computer). Please confirm with "Yes", and then follow the guided installation procedure to 
install the touchpad device driver to your computer.  
 

• Tools -> Input Device -> Print Calibration Pattern … (Alt+T+I+P): Selecting this option will open the 
calibration pattern SVG file and show the pattern with 9 points on screen. The paper size for this 
pattern is 11 inch by 14 inch in landscape mode. A tactile print of this pattern should have been 
delivered with your IVEO touchpad, but you can print a new copy now using IVEO application print 
options. (See section E. of this chapter below) 

 

 
IVEO application window when calibration from calibration pattern 

 

• Tools -> Input Device -> Calibrate Input Device … (Alt+T+I+C): With the hard copy of the embossed 
calibration pattern clamp on to the Touchpad in correct registration position, after selecting this 
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command, touch point 1 through 9 one after the other confirming with the SPACE key after each 
point. This will calibrate linearity of the IVEO touchpad. 
 

 
IVEO Player "Tools" menu item "Calibrate From Current Image" 

 

• Tools -> Calibrate from Current Image (Ctrl+U, or Alt+T+U): This requires to have an embossed output 
of currently opened SVG file, which needs to be clamped on to the Touchpad in correct registration 
position. Then, after selecting this command, touch the top left, and bottom right corners of the image 
frame confirming with the SPACE key after each corner point.  
This calibration from current image is recommended to be performed anytime you notice inaccuracy 
of the IVEO application in recognizing objects by touch. 

 

Calibrating the IVEO Pen or Windows Touch Screen Device 

To calibrate positioning of tactile points of the embossed output to corresponding x, y coordinates of the 
SVG image loaded into IVEO application, when working with the IVEO Pen or with another Windows Touch 
Screen Device, only option "Calibrate From Current Image" is needed. Other options explained under 
"Calibrating the IVEO Touchpad" above are not applicable in this case.  
 

 
IVEO Player "Tools" menu item "Calibrate From Current Image" 

 

• Tools -> Calibrate from Current Image (Ctrl+U, or Alt+T+U): The IVEO Pen receiver clamp needs to be 
attached to the top right corner of the embossed output of currently opened SVG file, or the 
embossed paper needs to be fixed on a Windows Touch Screen Device. After selecting this command, 
touch by touching the top left and lower right frame corners of the current image on the IVEO 
Touchpad. 
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C. Getting audio feedback 

The audio feedback given when exploring an SVG document is from information entered by the author of 
such document. This information was either entered in text form, or by connecting a sound file to an 
object within the SVG file. 
Possible text information entered for each object could be a title and a description. In general, the title is 
spoken when clicking an object once (direct mouse click, or with the aid of the IVEO input device), and the 
object description is spoken when clicking the object twice. But if a sound file was connected additionally, 
object properties are changed to a list of actions, which are played one by one subsequently with single 
clicks. 
 
The text information is played back to the user, utilizing IVEO Speech as explained in section II.D. above. 
Menu "Speech" in IVEO Player, or Creator actually, offers the following options.  
 

 
IVEO Player "Speech" menu 

 

• Enable Speech (Alt+S+S): Toggle switch to turn speech output completely ON, or OFF.  
 

• Speech Settings … (Alt+S+E): If no active screen reader application is running on the system, please 
make sure to have a voice installed compatible to MS Speech API Version 5 (SAPI5) to be used instead.  

 

 
IVEO Player "Speech Settings" dialog 
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Within the dialog that opens from this menu item, such voice can be selected from a drop down list, 
if several are installed. Additionally, users can change the volume, speed or pitch of the speech. A test 
button is available on the dialog to allow users to hear the speech produced by their choice of settings, 
before applying it. But please note, that an active screen reader application will always have priority 
over this selection. 
 

• Speak Title (F1, or Alt+S+T): Causes the IVEO application to read the title of the document if there is 
any. 
 

• Speak Description (F2, or Alt+S+D): Causes the IVEO application to read the description of the 
document if there is any. 

 

D. Tools for viewing documents in IVEO Player 

Menu "Tools" holds two commands that are meant to ease access when viewing documents in IVEO 
Player. These are "Simulate Mouse Click" and "Tablet Mode" as explained below. 
 

 
IVEO Player "Input Device" submenu item "Simulate Mouse Click" 

 

• Tools -> Input Device -> Simulate Mouse Click (F12, or Alt+T+I+M): When using this command, or 
pressing F12 on your keyboard, a mouse click will be performed at current position of pointer device 
(finger on touchpad, or IVEO pen position). Sometimes this is helpful when the actual tipping action 
can not be performed.   

 

 
IVEO Player "Tools" menu item "Tablet Mode" 

 

• Tools -> Tablet Mode (Shift+A, or Alt+T+A): Toggles the screen display between tablet mode and 
standard user interface. Tablet mode makes user menus invisible, so the whole area of a Windows 
Touch Screen Device can be used like a touch pad surface underneath a printed output. Menu 
commands can still be called through corresponding hot keys. 
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Further, IVEO Player provides menu "View" containing commands to change properties within current 
view.  
 

 
IVEO Player "View" menu 

 

• View -> Fit Page to Window (Alt+V+W): Fits the whole document in its page size to the boundaries of 
the IVEO application window. 

 

• View -> Enlarge View (Alt+V+I): Enlarges the view of the document within the application window. 
Please note, that current print out might not match dimensions of screen image anymore. This option 
is rather used when visually exploring SVG documents through screen display only. 

 

• View -> Reduce View (Alt+V+U): Reduces the view of the document in size within the application 
window. Please note, that current print out might not match dimensions of screen image anymore. 
This option is rather used when visually exploring SVG documents through screen display only. 

 

• View -> Enable Links (Ctrl+F9, or Alt+V+L): It is possible that the document contains objects which 
will lead to a new document. In this case a link to the new document would be executed when clicking 
corresponding object. This feature to follow links that are assigned to SVG objects within the 
document can be enabled, or disabled respectively, using this View menu command. 

 

• View -> Enable Sounds (Alt+V+S): Another possible feature from the SVG document is, that objects 
are assigned to sounds that are being played when clicking the object. This feature of playing the 
sounds can be enabled, or disabled respectively, using this View menu command. 

 

• View -> Views Manager (Alt+V+V): The author of the SVG document might have created different 
views of the subject, and saved them all to the same SVG file. In this case when opening the Views 
Manager using this View menu item, the following dialog window will show a list of all available view 
within that file, currently opened in IVEO Player.  
When selecting a specific view from the list, corresponding barcode index of this view will be shown 
within the display field to the right. This index can be used to identify the printed hard copy for the 
user to work with after the view opens within IVEO application window when selecting "OK" from the 
Views Manager dialog. 
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IVEO Player "Views Manager"  

   

• View -> Find Object (F3, or Alt+V+F): This option will assist you in finding an object from the document 
by touch. A dialog opens where the desired object can be selected from a list of all objects.  

 

 
IVEO Player "Find Object" dialog - object "lemon" is selected 

 
After confirming with "OK", the object that was selected by name will be highlighted within the 
image on screen.  
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IVEO Player - touch at indicated position would cause feedback message "left" 

 
When now clicking anywhere on the tactile output using the touchpad, or pen, the IVEO program will give 
direction to change the positioning of the touch to reach the object. When the user has clicked the object, 
it becomes selected, and IVEO Player will confirm with object found message. 
 

  



21 
 

E. Arranging document layout and creating new prints 

You have the possibility in IVEO Player to change the view of objects in respect to the displayed page and 
create new printouts from changed views to be able to work within them with the aid of IVEO input 
devices. Therefore options in menu "Arrange", as well as "Page Setup", and "Print" from menu "File" 
provide features as described in the following. 

Arrange Menu 

 
IVEO Player menu "Arrange" - document view after "Fit Canvas to Page" 

 

• Arrange -> Fit Canvas to Page (Ctrl+Page Up): Places the full figure in its original size along the left 
edge of the window. 
 

• Arrange -> Fit Selection to Page (Ctrl+Shift+Page Up): Fits the outer dimensions of the selected 
element to the outer dimensions of the screen so that either the length or width of the selected 
element matches the corresponding dimension of the window. 
 

• Arrange -> Zoom In (Page Up): Increases the size of the image on canvas so that more detail can be 
viewed. 
 

• Arrange -> Zoom Out (Page Down): Decreases the size of the image on canvas. 
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• Arrange -> Zoom Rectangle (Shift+Page Up): Allows the user to select two points diagonal from each 
other, defining a rectangle. Each point need to be confirmed with SPACE. The rectangle will then 
behave like an element selected for the "Fit Selection to Page" command. 
 

• Arrange -> Pan Up (Ctrl+Shift+Up): Moves the entire image farther up on the screen. 
 

• Arrange -> Pan Down (Ctrl+Shift+Down): Moves the entire image farther down on the screen. 
 

• Arrange -> Pan Left (Crtl+Shift+Left): Moves the entire image farther to the left of the screen. 
 

• Arrange -> Pan Right (Ctrl+Shift+Right): Moves the entire image farther to the right of the screen. 
 

 
IVEO Player document view after "Zoom Out" and "Pan Right" 
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Page Setup and printing 

When you have arranged a new view in IVEO Player, you need the corresponding print to further exploring 
the SCG by touch and get correct audio feedback to the objects you are touching. Depending on printing 
capabilities with hardware on hand, you need to make sure to adjust page setup to paper size that you 
can print. 
Therefore use "File" menu item "Page Setup", and then "File" menu item "Print" to create a new tactile 
image to explore. 
 

 
IVEO Player "File" menu item "Page Setup" 

 

• File -> Page Setup (Alt+F+G): Allows the user to select page printing options, including a specific form 
size, or the page width and height for custom size, portrait or landscape print mode, vertical and 
horizontal margins. The view of the current file will be adjusted to the page setup options and the 
user will be asked to fit the full image of the current open file to the new paper size, or not. If not the 
current view will keep its scale in respect to the new paper size.  
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IVEO Player "File" menu item "Print" 

 

• File -> Print (Ctrl+P, or Alt+F+P): Prints, or embosses the current file according to page setup options. 
If you have arranged a different view of the document, or specific objects, you can create a new 
printout corresponding to that view to then further explore the SVG file from this view.   
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F. User preference settings in IVEO Player 

Certain user preference settings are available through IVEO Player "Tools" menu item "Options …". A 
dialog window will open as in pictures below. 
 

 
IVEO Player "Tools" menu item "Options …" dialog - User Interface 

 

• Tools -> Options … (Alt+T+O) - User Interface settings: The first focus will be on user interface settings 
when opening the dialog. Here you can select preferences for the user interface language of the IVEO 
application, and font name and size for displayed text, as well as units of measurement, which will be 
applied when choosing page layout options. 
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IVEO Player "Tools" menu item "Options …" dialog - Navigation 

 

• Tools -> Options … (Alt+T+O) - Navigation settings: The next focus will be on navigation settings, 
which include zoom step, pan step, and pointer size, as well as a choice of function mode for a mouse 
scrolling wheel. The choice here is Zoom function, or Pan function. 
Also within Navigation settings here the user can turn "Follow Pen Movement" ON, or OFF by check 
box. If turned on, when using the IVEO Pen input device, the Pen pointer symbol on document view 
will follow the Pen movement, even when the Pen is not touching the printout. If turned off, the Pen 
pointer symbol will jump from Pen touch to Pen touch. 
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IVEO Player "Tools" menu item "Options …" dialog - Print Options 

 

• Tools -> Options … (Alt+T+O) - Print Options: The last focus on the Tools Options dialog contains 
options for printouts that are being created using the print command from menu "File".  The choices 
are to turn embossing of the tactile barcode and image frame corners (fiducials) ON, or OFF, to turn 
printing of color barcode ON, or OFF, and to select the Braille font to be used when embossing Braille 
labels. 
 

On all pages within the settings dialog, there are three buttons available.  

"Reset to Default Settings" to have all options from current view set back to what the factory default  
    values are. 
"OK"     to confirm you settings changes and leave the dialog. 
"Cancel"   to close the dialog window and cancel all changes you made, reverting  
    back to the previous state of settings values.  
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G. Help Menu items 

The Help menu within the IVEO application offers following options. 
 

 
IVEO Player "Help" menu 

 

• Help -> Online Help (Ctrl+F1, or Alt+H+O): Will lead to IVEO user manual on ViewPlus website. 
 

• Help -> Check for Updates (Alt+H+C): Checks for IVEO software updates. If an update is available, the 
user is notified and is given the choice of whether to install the update.  
 

• Help -> About (Alt+H+A): Displays the opening splash screen, giving software information, including 
the version number and user license number.  
 

• Help -> Deactivate (Alt+H+D): The user is given options to deactivate as described under section II.B. 
("Deactivation and Uninstallation") above. Deactivation would be necessary, for example, if 
transferring the product license to a different computer.  
 

• Help -> Check Activation (Alt+H+C): Will give notice of activation status of the product. If currently 
not activated, this option will call the activation dialog giving choices to activate as explained in section 
II.A. ("Software installation and activation") above. 
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IV. Using IVEO Creator 
 
Additional to functionality of IVEO Player, which is included in IVEO Creator, the Creator also includes 
functionality to create new SVG files, or edit existing files. It can be used to view as well as author/edit 
SVG files.  
An IVEO SVG file has features not normally found in common SVG files, including a page layout (size, 
orientation, margins) and an index (used to correlate the file with tactile copies printed from it). IVEO 
Creator adds these features to SVG files, and also permits users to add much more information about the 
file and about single SVG objects within the SVG document. 
 
The following is a reference to all commands and features available in IVEO Creator, which have not 
already been explained within IVEO Player chapter above. 
 

 
IVEO Creator main application window 

 
The picture above shows the IVEO Creator main application window upon start-up of the application. Pick 
an option from the dialog for file opening, but depending on your preference you can also just close this 
dialog and open a file through command menu "File", which is the first one from the menu bar at the top 
left. 
The file opener dialog also shows a checkbox to switch the appearance of this dialog off for any future 
start-ups of the application. This option can also be found under IVEO Creator user preference settings 
within menu item "Options" of menu "Tools" (see section F. below). 
The main application window of IVEO Creator as seen in the picture above also shows a toolbar just below 
the pull-down menu bar at the top. Moving your mouse pointer over these toolbar icons will tell you what 
commands they are triggering. You will find reference to all these commands within the pull-down menus 
and explanations for it.   
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A. File Menu 

• File -> New (Ctrl+N, or Alt+F+N): Opens the page setup dialog for the user to specify desired page 
settings. The new file is created when clicking the "OK" button on this dialog. 
 

• File -> Reload (Ctrl+L, or Alt+F+L): Reloads the currently opened file in its last saved state.  
 

• File -> Barcode -> Show Barcode Library (Ctrl+Shift+B): This command will open a dialog window 
showing a list of all available IVEO files from the standard IVEO folder. The list is given in columns 
"Index", "File Name", and "Description".  
Any file can be picked within either of these three columns and will open upon clicking the "Open" 
button below. Button "Sort" will sort the list by entries within that column, which shows any entry 
selected currently. 
 

• File -> Save (Ctrl+S, or Alt+F+S): Saves a file under the same name and file type as currently opened. 
 

• File -> Save As (Ctrl+A, or Alt+F+A): Saves the current view of a file. A standard Windows file browser 
will open where a new name and/or file type can be chosen using this command. 

 

• File -> Export As (Alt+F+E): Current document view can be exported using this command and saved 
in file type PNG, JPG, or TIFF. Upon choosing the desired file type from following submenu a standard 
Windows file browser will open to choose custom location for file save. 

 

B. Edit Menu 

 
IVEO Creator "Edit" menu 
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• Edit -> Undo (Ctrl+Z, or Alt+E+U): Allows you to undo previous action. This useful tool lists the name 
of the action just taken, so the user can determine what will be changed. 

 

• Edit -> Redo (Ctrl+Y, or Alt+E+R): If you would like to revert back the undo action, clicking on this 
function will take back previous undo action.  

 

• Edit -> Copy (Ctrl+C, or Alt+E+C): This will copy current selection within document to clipboard.  
 

• Edit -> Paste (Ctrl+V, or Alt+E+P): This will paste clipboard content into the current document.  
 

Please note, if you copy and paste a selection within one document, the duplication will be placed exactly 
on top of the original. Use the next command "Duplicate selection", to place the duplication with an offset 
to the original. An offset which is defined in user preference settings as explained in section F. ("Tools 
Menu") below. 

 

• Edit -> Duplicate Selection (Alt+E+U): This commands combines copy and paste functionality, 
duplicating all elements that are currently selected.  

 

• Edit -> Copy Element Attributes (Alt+E+I): Imports the fill and line drawing properties of the next 
element selected. When you draw any shape afterwards, these properties will be applied. 

 

• Edit -> Select Elements (Ctrl+E, Alt+E+M): Allows the user to select multiple elements at once. When 
calling this command you will be asked to click an upper left corner, and a bottom right corner of a 
rectangle to select items. Everything that even partly lays within the boundaries of this rectangle will 
be selected.  

 

• Edit -> Select Text Tool (Ctrl+T, or Alt+E+T): Allows the user to select all text within the boundaries of 
a selection rectangle at once. As in "Select Elements" you will be asked to define the rectangle 
selection area by upper left, and bottom right corner points, and all text objects touching this 
rectangle will be selected at once. 

 

• Edit -> Select All (Ctrl+A, or Alt+E+A): This command will select all elements to be found within the 
open SVG document at once.  

 

• Edit -> Select All Text (Alt+E+E): This command will select all text objects to be found within the open 
SVG document at once.  

 

• Edit -> Create New Layer … (Alt+E+C): Use this command to add a new layer to the SVG document. A 
dialog will open for a name to be specified for the new layer, which will be added when confirming 
with "OK".  

 
Layers can be used to create different data for color print output than for embosser output, or to 
differentiate between elements/object that are supposed to be voiced, and those that should not be 
associated with audio feedback. The commands to create layers and add elements to specific layers are 
described here, but find explanation on how to set layer properties within section C. ("View Menu") below.   
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• Edit -> Add to Layer (Alt+E+E+E): Something should be selected when calling this command for 
current selection to be added to a specific  layer. A dialog will open with a list of available layers. Select 
the layer you want to add to by name and confirm with "OK".  
This command is also available from right mouse click context menu on selected element, but named 
"Move to layer" in that case.  

 

• Edit -> Edit Document Description …: Allows the user to edit the document title and description in 
following dialog window.  

 

 
IVEO Creator "Edit Document Description" dialog  

 
The Title and description that are entered here will be voiced each time the file is opened. 
Additionally, this is the information that is being voiced when selecting "Speak Title" (F1), or "Speak 
Description" (F2) respectively from menu "Speech" in IVEO Creator, or IVEO Player. 
 
When selecting button "Advanced" within the dialog as shown in picture above, the dialog will expand 
to show further attributes that can be edited by advanced users with programming skills in 
SVG/HTML5 language. 

 

Element Properties and levels of information 

• Edit -> Edit Element Properties … (Alt+Enter): In general this will open the same dialog as "Edit 
Document Description", but the "Add Actions" feature will be enabled, which is disabled for document 
properties. An element has to be selected within the document before calling this command. 



33 
 

You can enter title and description for the selected element/object, and then this information will be 
voiced to the user when clicking/touching the object once, or twice respectively while reading the 
SVG.  
 
Further attributes can be edited when selecting button "Advanced" as in option "Edit Document 
Description" above.  
 

 
IVEO Creator "Edit Element Properties" dialogs 

 
Additionally, actions can be added to element properties. When clicking button "Add Actions", the 
next dialog will open, showing already entered actions, or another dialog offering an "Add Level" 
button if now action was available yet. Please note that actions have priority over title and description. 
As soon as the first action is added, title and description, if containing any data, will also become 
action items and former title and description entry fields will be ignored in element properties from 
now on. 
The "Levels of Information" dialog will show all actions currently entered for the selected 
element/object. The small button to the right of each level of information will open a context menu 
for adding and removing levels, or changing the order of appearance. The actions will be voiced, or 
played one after the other in the order as given here with subsequent single clicks/touches on the 
element by the end user while reading the SVG. 
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IVEO Creator "Levels of Information" dialog 

 
The setup for each level of information is to choose whether it should be text that will be 
spoken/voiced to the end user, or a file given by link that should be played while the end user is 
reading the SVG. That's the first choice with "speak", or "link" in field "Type" for the action.  
 

 
IVEO Creator editing levels of information 

 
To edit field "Value" you have to call the context menu again from the small button to the right of that 
action line. Select "Edit Level" from this context menu. 
 

 
IVEO Creator editing levels of information 

 
If the action is of type "link", the next dialog will offer an entry field for file location to link to. You can 
use button "Browse…" to open a standard Windows file browser to find the file. Another option here 
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is to record something with the help of buttons "Record", and "Play", and create your own sound file 
this way, which will then be linked to the element in this level of information. 
 

 
IVEO Creator editing levels of information 

 
If the action is of type "speak", the next dialog offers an entry field to type text, which will be voiced 
in this level of information. 

 

• Edit -> Edit Levels of Information …: Will open the "Level of Information" dialog for selected element 
without going through element properties dialog first.  

 

• Edit -> Convert to Overlay (Ctrl+Shift+O, or Alt+E+O): Converts the selected element to an overlay. 
An overlay is a transparent shape, which is helpful to add audible information to only parts of an 
image, for example. Place an invisible overlay in custom shape over part of an image and add levels 
of information to this overlay instead of the full image object. Audio feedback is given back only when 
the area of the invisible overlay is touched/clicked within the fully visible image. 

 

• Edit -> Delete Selection (Delete, or Alt+E+D): Deletes current selection from the document. 
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C. View Menu 

 
IVEO Creator "View" menu 

 

• View -> Print & Tactile View (F4): Shows all and only elements whose layer property "display" is ON. 
A document view representing combined color print and embossed output can be achieved utilizing 
this feature. See description of "Layers List" below to learn how layer properties are managed.  

 

• View -> Print View (F5): Shows all and only elements whose layer property "print" is ON. A document 
view representing color print output only can be achieved utilizing this feature. See description of 
"Layers List" below to learn how layer properties are managed. 

 

• View -> Tactile View (F6): Shows all and only elements whose layer property "emboss" is ON. A 
document view representing embossed output only can be achieved utilizing this feature. See 
description of "Layers List" below to learn how layer properties are managed. 

 

• View -> Toolbar (F7): Toggles the IVEO Creator toolbar between show, and hide. Hiding prevents 
accidental activation by blind users. 

 

• View -> Overlays (F8): Shows or hides overlay elements. When active, overlays are displayed as light 
blue elements. When not active, overlays are not displayed, but still exist. 

 

• View -> Links (Alt+V+L): Indicates elements, that have links implemented in any level of information, 
by drawing pink boxes around them. These pink boxes are toggled to show, or hide using this 
command. 
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• View -> Layers List (Shift+L): Opens a dialog, which will list all layers from the document together with 
layer properties. Layer properties can be turned ON, or OFF in this initial dialog, or a layer can be 
selected and the "Edit Layer Properties" dialog can be called using button "Layer Properties". 

 

 
IVEO Creator "Layers List" dialogs 

 

Layer Properties 

Layer properties will have following effect: 

display: When ON, content of this layer will be shown in "Print & Tactile View" (F4), when 
turned OFF it will not. 

print: When ON, content of this layer will be shown in "Print View" (F5), and at the same 
time it will only be printed in color on print output when this property is turned ON. 
When turned OFF both of this will not happen with elements on this layer. 

emboss: When ON, content of this layer will be shown in "Tactile View" (F6), and at the same 
time it will only be embossed on print output when this property is turned ON. When 
turned OFF both of this will not happen with elements on this layer. 

speak: Audio feedback will only be given from audible information of elements from this 
layer when this property is ON. When turned OFF, no audio feedback will come from 
elements of this layer. 

Enabled in Player: When this property is turned ON, the layer content will be available when opening 
the SVG file in IVEO Player. When turned OFF, it will not be there. 
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If enabled for IVEO Player, other layer property settings will transfer and apply as 
defined and saved to the SVG file here in IVEO Creator. 
For example, if "display" is OFF, but "emboss" is ON when saving in IVEO Creator, 
elements from corresponding layer will not show within IVEO Player, but will still be 
embossed when creating a print output from IVEO Player. 
IVEO Player does not offer "Print View", or "Tactile View", but generally displays in 
"Print & Tactile View". 

lock: When ON, the layer will be locked for any further editing. 
 
 

• View -> Show Braille (F9): This command will toggle Braille labels to show, or hide. 
 

Managing Views 

• View -> Views Manager (Alt+V+V): The dialog that opens with this command is a little bit different 
than the dialog opening with the same command in IVEO Player. 

 

 
IVEO Creator "Views Manager" dialog 

 
Besides selecting a certain view to be switching to in main application window, here in IVEO Creator 
you can remove and rename views and change their order of appearance. Additionally, the barcode 
index for each view not only displays, but can also be edited here. These features allow the author to 
define a library of views, sorted by name and/or barcode index as would make sense for the end user. 
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• View -> Save Current View (Alt+V+S): After editing a view, or creating a new view, use this feature to 
save the view under a new name to the SVG data base. After saving it here, the new view will be 
available through "Views Manager". 
 

D. Insert Menu 

 
IVEO Creator "Insert" menu 

 

• Insert -> Image (Ctrl+Shift+I): Allows the user to insert a JPG, JPEG, or PNG image to the document. 
 

• Insert -> Text (Ctrl+Shift+T): When using this command, click the desired text position within the 
document and then a dialog will open, giving the opportunity to enter text which will appear within 
document view corresponding to given properties after confirming with "OK". 

 

• Insert -> Braille (Ctrl+Shift+B): When using this command, click the desired Braille label position 
within the document and then a dialog will open, giving the opportunity to enter text which will be 
translated to Braille applying specified Braille font and will be displayed as Braille label within 
document view after confirming with "OK". 

 

• Insert -> Oval (Ctrl+Shift+V):  Switches to oval mode. Adds ovals, one at a time, which become 
separate elements. Oval mode can be ended by pressing Ctrl+Shift+M. 

 

• Insert -> Rectangle (Ctrl+Shift+R): Switches to rectangle mode. Allows the user to add any number of 
rectangles as separate elements. Rectangle mode can be ended by pressing Ctrl+Shift+M. 
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• Insert -> Line Shape (Ctrl+Shift+P): Switches to line mode. Allows the user to draw freeform lines 
using the mouse pointer. The line will follow the movement of the mouse pointer as long as the left 
mouse button is activated. It ends with releasing the mouse click and the line becomes a separate 
elements. Among other uses, the polyline option may be used for adding signatures to documents to 
be printed. 

 

• Insert -> Filled Shape (Ctrl+Shift+L): Switches to filled line mode (or filled freeform shape) mode. 
Works the same as "Line Shape", but filling areas between and around the created line. 

 
Please note, that the length of drawing segments when using "Line Shape", or "Filled Shape" commands 
can be defined in user preference settings as explained in section F. ("Tools Menu") below. 

 

• Insert -> Polygonal Shape (Ctrl+Shift+G): Switches to polygon mode. Allows the user to click two 
points to draw a straight line and continue clicking to draw additional straight lines connected to the 
end point of the last straight line. A polygon can be finished by pressing ESC. 

 

• Insert -> Curved Shape (Ctrl+Shift+C): Switches to curve mode. Allows the user to draw curves by 
clicking a starting point, two curve points and an ending point. Until the space bar is pressed, a 
continuous string of curves can be drawn. Drawing curves can be finished by pressing ESC. 

 

• Insert -> Insert -> Custom Shape -> a choice of custom shapes in following submenu: Allows the user 
to draw a shape that is being picked from the submenu of this menu item. Pick the desired shape and 
draw within the document view by clicking, pulling and releasing with the mouse. 

 

• Insert -> Selection Mode (Ctrl+Shift+M): Brings the user out of any insert or editing shapes mode and 
allows the user to once again select elements to trigger feedback of element information and actions. 
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E. Arrange Menu 

 
IVEO Creator "Arrange" menu 

 

• Arrange -> Bring Forward (Alt+A+W): Moves the selected element forward one level. 
 

• Arrange -> Bring to Front (Alt+A+F): Moves the selected element in front of all other elements. 
 

• Arrange -> Bring Backward (Alt+A+A): Moves the selected element backward one level. 
 

• Arrange -> Bring to Back (Alt+A+B):  Moves the selected element behind all other elements. 
 

• Arrange -> Rotate Selection: Allows the user to click on an element and rotate it. 
 

• Arrange -> Scale Selection: Allows the user to click on an element and change the size. Drag the corner 
to maintain the same shape. To enlarge one dimension, use one of the points on the side of the 
element and drag the side until the element is the desired size. 

 

• Arrange -> Move Selected Elements: Allows the user to click on an element and drag it with the 
mouse to move to a different position within document view. To move several elements at the same 
time, click on the first element, hold down Ctrl, or Shift and click on any additional elements to add to 
the selection for movement. 
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More Toolbar Icons 
 

 
IVEO Creator Toolbar 

 
You will find two icons within the Toolbar at the top of the application window, which have no menu items 
associated to them. Those two are indicated in the picture above. The command are as follows. 
 

• Edit Element's Geometry: Allows the user to edit the geometry of the element according to the rules 
for drawing that type of element. 

 

• Select Color / Style: Allows the user to change fill and line properties of existing elements or to set 
the properties desired for elements he/she plans to draw. Alterable properties include fill or line 
presence, color and opacity and line width. 

 

F. Tools Menu 

 
IVEO Creator "Tools" menu item "Options" 

 
The user preference settings opened upon selecting menu item "Options …" from menu "Tools" in IVEO 
Creator are extended versus settings available in IVEO Player. Only these extensions will be explained 
below. See section III.F ("User preference settings in IVEO Player") in this manual above for description of 
other options. 
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IVEO Creator user preference settings "User Interface" 

 

• Tools -> Options … (Alt+T+O) - User Interface: The only difference on this page versus the same dialog 
in IVEO Player is option "Display Welcome Screen on Startup" to be turned ON, or OFF by checkbox. 
This is referring to the smaller screen containing file opening options as shown and explained in the 
beginning of this chapter III. ("Using IVEO Creator") above.  
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IVEO Creator user preference settings "Editing" 

 

• Tools -> Options … (Alt+T+O) - Editing: This is an additional page within this user preference settings 
dialog, only available in IVEO Creator. 
The shape drawing segment length is referring to segments when you draw polylines using the "Line 
Shape", or "Filled Shape" command from menu "Insert". 
The duplicated element X and Y Offset will be applied when using "Duplicate Selection" command 
from menu "Edit".  
 

 
 

Other commands and features of IVEO Creator, which are not described in this 
chapter, might be the same as in IVEO Player and therefore have already been 

described in chapter III. ("Getting Started with IVEO Player") above. 
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IVEO Help and Support 
 
 
Please also visit ViewPlus Support online for other resources and support inquiries. 
 
 
Additional training and support is available for purchase through your authorized ViewPlus distributor or 
from ViewPlus Technologies. 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

ViewPlus Technologies, Inc. 
1965 SW Airport Ave. 
Corvallis, OR 97333 

Toll free phone number: 866.836.2184 
www.viewplus.com 

http://www.viewplus.com/support/
http://www.viewplus.com/support/
http://www.viewplus.com/support/
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